SoftEther VPNとIX2105でポン付けVPN

お久しぶりです。

最近、全くブログを書いていませんでしたが、このブログはとりあえず動いています。

今回は題目の通り、IX2105をポン付けしたら自宅につながるようにしたいと思います。

SoftEther VPN Serverが構築済みで、L2TP/IPSecでVPNが掘れることが前提条件となります。
(ググればいっぱい出てくるので書きたくない)

今回は以下の条件でconfigを構築していきます。

項目
トンネル方式 EtherIP over IPSec
SoftEther側 FQDN test-vpn.softether.net
SoftEther側 ローカルIP 172.16.1.0 / 24
ISAKMP 共有シークレット KeyVisualArts20th

とりあえずIX2105のconfigを構築して流し込んでいきたいと思います。

! タイムゾーンの設定
timezone +09 00
!
! UFSキャッシュの有効化とファイアウォール素通しの設定
ip ufs-cache enable
ip access-list access-list permit ip src any dest any
ipv6 ufs-cache enable
ipv6 access-list sec-list permit ip src any dest any
!
! ISAKMPのプロポーザルの設定
ike proposal ike-prop encryption aes hash sha group 1024-bit lifetime 3600
!
! ISAKMPのポリシー設定
ike policy ike-policy peer-fqdn-ipv4 imas-anzu.softether.net key vpn mode aggressive ike-prop
ike keepalive ike-policy 10 2
ike local-id ike-policy keyid ix2105
ike nat-traversal policy ike-policy keepalive 10
!
! IPSecのプロポーザルの設定
ipsec autokey-proposal ipsec-prop esp-aes esp-sha lifetime time 3600
ipsec autokey-map ipsec-map access-list peer-fqdn-ipv4 imas-anzu.softether.net ipsec-prop
!
! ブリッジインターフェイスの有効化
bridge irb enable
!
! DNSの設定
proxy-dns ip enable
proxy-dns ip request both
proxy-dns ipv6 enable
!
! keepaliveの設定(IKEv1にはkeepaliveがないのでパケットを飛ばし続ける)
watch-group keepalive 10
  event 10 ip unreach-host 172.16.1.1 BVI1 source BVI1
  ! ここのアドレスは対向にある適当な機器(ルータとか)のIPを指定する
!
network-monitor keepalive enable
!
!       
device GigaEthernet0
!
device GigaEthernet1
!
! GE0の設定(DHCPでIPを拾うだけ)
interface GigaEthernet0.0
  ip address dhcp receive-default
  no shutdown
!
! GE1の設定(ブリッジインターフェイスに所属させる)
interface GigaEthernet1.0
  no ip address
  bridge-group 1
  no shutdown
!
! ブリッジインターフェイスの設定
interface BVI1
  ip address 172.16.1.254/24
  ! ブリッジインターフェイスのIPアドレスは対向に存在し得るアドレスにする
  bridge-group 1
  no shutdown
!
! トンネルインターフェイスの設定 (ブリッジインターフェイスに所属させる)
interface Tunnel0.0
  tunnel mode ether-ip ipsec
  no ip address
  ipsec policy tunnel ipsec-map out
  bridge-group 1
  no shutdown

次にSoftEther側の設定をしていきます。

GUI設定画面を開いたら、L2TP/IPSecの設定を開きます


「EtherIP / L2TPv3 over IPSec サーバー機能有効」にチェックをつけて、「サーバー機能の詳細」をクリックします。


「追加」をクリックします


各項目を、よしなに入力して、OKを押します。

以上で設定は完了です。

IX2105を適当にDHCPが降ってくる環境に接続すると自動的にVPNトンネルを掘りに行くようになったと思います。

もし、トンネルが掘られない場合は、IX2105やSoftEtherのログを漁ってみてください。
あと、場所によってはUDPの500番と4500番のoutboundを切られていることがあるため、掘れない場合があります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください